Hello ! Inside the new Execute code window I can s...
# đź’»developers
n
Hello ! Inside the new Execute code window I can see my variable having the value I want it to but outside, in the Variables table on the left, the variable is Empty.. tried refresh, close and reopen, log out and back in but still. The variable shows like it has the correct value stored within the execute code window (when I hover the mouse over it) after I run the bot, but outside the execute code window the variable is shown as Empty. Also I try to print the variable after I run the code and it prints empty. Variable is type Object. Any ideas? Apparently there was an "await" that had to be added before the result of the response was stored in the variable: workflow.airtableResponse = await getListOfUserRecords(); And the whole thing had to be done outside the function. This will prob be lost in the posts, if anybody in @cold-motherboard-82208 would like to make a note for other users to be noted. It happened with calls to the airtable API.