https://discord.gg/botpress logo
#🤝help
Including Links in Knowledge Base Queries
# 🤝help
b

bland-jelly-85439

07/10/2023, 8:30 PM
Hello I have a plain text Knowledge base in the form of Q: A: Botpress does a great job at finding the appropriate answer for my questions. However, as part of those answers I have included a URL to a blog post for more information. Bot press ignores all of the URLS in my FAQ and only sends the message. How can I make it include the URL in the response? Here is a specific example: Q: Why is the sky blue? A: Sunlight reaches Earth's atmosphere and is scattered in all directions by all the gases and particles in the air. Blue light is scattered more than the other colors because it travels as shorter, smaller waves. This is why we see a blue sky most of the time. https://spaceplace.nasa.gov/blue-sky/en/#:~:text=The%20Short%20Answer%3A,sky%20most%20of%20the%20time.
q

quick-sunset-51605

07/11/2023, 10:52 PM
I haven't tested this, but if you want a hyperlink to show in a message that has some words that are different than the link, it needs to be formatted like this: [Link](https://www.google.com). I wonder if setting it up in a similar way in the knowledge base would work?
b

bland-jelly-85439

07/12/2023, 6:47 PM
This did not work for me. It will give me all of the answer but will not include the link even with that formatting. Botpresses website FAQ says "For best practices, you should add questions and answers on an Excel spreadsheet you want your bot to answer". But there is no ability to add csv files to Knowledgebases. I thought this might make it give full answers. I am also finding that on some questions bot press will only give the first sentence of an answer and not the full answer. Is there any way to fix this as well?
q

quick-sunset-51605

07/12/2023, 7:41 PM
Hey I juste saw this message in the general channel, might apply: Apparently the link in the knowledge base needs to start with www. and it only accecepts .com domains
b

bland-jelly-85439

07/12/2023, 9:41 PM
Thanks for getting back to me. I have tried reformatting my links as www. with .com domains. No dice still. It just will not respond with a link.
i'm using a super simple link for testing too. www.xyz.com/reviews no dice.
17 Views