https://discord.gg/botpress logo
#🤝help
Changing bot language
# 🤝help
e

eager-author-6956

06/30/2023, 2:00 PM
Hey guys, how can i change the language of my bot? Whenever i click on chatbot settings the only thing i can change is the name of my bot. There ist no section where i can change the language. Could somenone please help me out?
a

acoustic-hair-60678

07/01/2023, 12:01 AM
hi @eager-author-6956 👋 this quick vid should help: https://www.youtube.com/shorts/SIrmuihqNhs
Language setting now happens in the Translator Agent
a

adamant-morning-73102

07/01/2023, 8:59 AM
Hi, the "pro tip" doesnt work for me. I left the language empty and the bot is not translating text to the users language
e

early-train-33247

07/02/2023, 2:06 AM
Hey @adamant-morning-73102, go to the Translator Agent settings, and make sure it looks like this:
a

adamant-morning-73102

07/02/2023, 5:17 AM
Hi :), yea I already have it just like that, Although I only tried it in dev environment, I will give it a go in the production
e

early-train-33247

07/02/2023, 9:44 PM
Alright, let me know if it works
a

adamant-morning-73102

07/03/2023, 2:53 PM
Hi, sorry, I was dealing with others stuff so I forgot 😄 It doesn't even work in the prodcution. Only AI translates their text, but the text thats inside "text block" is set in the language that it was written in. It only worsk if I hard set the translation agent to the language I want
e

early-train-33247

07/04/2023, 1:06 AM
That's odd. If confirmed it's probably a bug. Try removing the set language card, and reenabling your agent with both options checked. @adamant-morning-73102
a

adamant-morning-73102

07/04/2023, 5:12 AM
HI, tried it, but still the same
e

early-train-33247

07/05/2023, 12:39 AM
Hey @adamant-morning-73102 could you explain the problem again, please?
a

adamant-morning-73102

07/05/2023, 5:11 AM
HI, sure. I basicaly want the bot to reply in the language of the user, so I have this starting node with a greeting and language detector on the top. But the bot just ignores the users language and replies in english. I have the "set users language" blank as said in the video. It only works if I hard set tne language code
e

early-train-33247

07/05/2023, 1:21 PM
Try removing the set user language card, since its purpose is to hard set. Then make sure the Translator Agent is enabled with all options checked.
a

adamant-morning-73102

07/05/2023, 2:30 PM
I tried it without it and it doesnt work either 😦
l

lemon-tent-14722

07/05/2023, 11:07 PM
I am also facing this issue
r

rough-magician-49397

07/06/2023, 8:44 AM
Yeah im in the same situation here. Bot sometimes answers in english instead of the user's language. Not everytime, but sometimes.
b

brief-optician-17668

07/06/2023, 8:47 AM
It keeps changing the language in the middle of a conversation. Can anyone help? Do I need to "Set User Language" Agent on every node?
r

rough-magician-49397

07/06/2023, 8:51 AM
Even tho i put it on every node, it still changing the language. Its odd because in the emulator i see the answer poping in the language i want and then it does a translate job back to english.
I can see that in older version you could just pre-select the language of the bot, it seemed better
g

gifted-minister-2714

07/06/2023, 2:35 PM
Agree, tried to set the language to Russian, but bot only answers in Russian when I specifically ask him to in the dialogue window. It never texts the first message in Russian
r

rough-magician-49397

07/06/2023, 3:13 PM
#1111009377525186570
Hey the language issue might be happening because your Translator Agent has the "Detect on Every Turn" option enabled!
a

adamant-morning-73102

07/07/2023, 7:46 PM
Will try that out, thanks
38 Views