https://discord.gg/botpress logo
#🤝help
intents
# 🤝help
r

rough-magician-49397

07/24/2023, 7:32 PM
Here we go. I post here the bug of the intent section. And the print of how the confience is working with the sentence i used onm the right. It is having 99% confidence that the intent is cancel when clearly the message isnt about it. https://cdn.discordapp.com/attachments/1133119431673925662/1133119432223359106/Enregistrement_2023-07-24_211313.mp4

https://cdn.discordapp.com/attachments/1133119431673925662/1133119433049649243/Capture_decran_2023-07-24_212948.png

i created this bot just with the intents, intents dont need entities right ? i mean i did them in the other bot before deleting it but its simple stuff i can add it if needed in the process of checking what is going wrong. the last test is in this bot anyway without entites https://cdn.discordapp.com/attachments/1133119431673925662/1133119793239703614/brave-tapir_-_2023_Jul_24.bpz
@red-rocket-93714
I have a demo in 2 weeks for a real estate agency. I have 2 options here, have multiple single choice for Location/price etc, or with the NLU and entites and intents. I rather go with intents if it works cuz it has a more "wow" effect on clients. I can go the "easier" way, but its reaaaally not what i want. if you can save me jesse ill credit you hahaha ^^
r

red-rocket-93714

07/24/2023, 8:39 PM
Awesome! Okay, just out of a meeting. For the intent editing... Which browser are you using, on which OS? It worked well for me, so I tend to want tell you to switch to Chrome on Windows, but that may be unreasonable 😂 . If you could try a different browser for that one, it would be helpful. Now... I got it working, but I did have a funny issue... I had to make a change to the intent (added a dot on a random utterance, wait for training to complete, add the dot back in), and literally refresh the page. Nothing else worked. The refresh was critical here. Well, I also enabled and disabled the Summary and Knowledge Agents before I edited the intent because I had some call errors on those so unsure if that affected anything, but worth a try. I attached the "edited" bot here, maybe one works for you? Next step if that all fails... can you check your network logs from the browser developer console to see if any request are erroring out?

https://cdn.discordapp.com/attachments/1133119431673925662/1133136484124336228/image.png

https://cdn.discordapp.com/attachments/1133119431673925662/1133136484334043156/wise-bear_-_2023_Jul_24.bpz
r

rough-magician-49397

07/24/2023, 10:29 PM
Ok switching to google chrome fixed the intent page issue. which is great. now i just ask a related question have a 99.2% confidence and still not trigger the transition.

https://cdn.discordapp.com/attachments/1133119431673925662/1133164980284440726/test1.png

maybe @early-train-33247 you have a solution here ?

https://cdn.discordapp.com/attachments/1133119431673925662/1133165876892422205/test2.png

maybe a way to delete yes no and cancel intents so it cant interefere ?
ok i deleted everything inside cancel no and yes, finally its getting it
r

red-rocket-93714

07/25/2023, 12:12 AM
Odd that the confidence for the intent shows so high in the debugger, yet the logs show hits on the default intents (yes, no, cancel). I'll be sure to share this with the team.
e

early-train-33247

07/27/2023, 6:28 PM
@red-rocket-93714, i've seen some issues with the "cancel" intent being triggered for totally unrelated user inputs. Should we create an issue?
r

red-rocket-93714

07/27/2023, 6:40 PM
@early-train-33247 please do!
r

rough-magician-49397

07/27/2023, 8:35 PM
Thanks guys
I had to remove everything on yes and no and cancel for it to work