Raw Input suddenly stopped capturing choices - but...
# 🤝help
s
Without any modification to the flow, after one day, Raw Input suddenly stopped reacting to the buttons "Yes" and "No." I had to change it to the Boolean card because I could not solve it any other way. I tried adding new nodes and a new Raw Input card, but the behaviour remained the same. The flow ended because it exited Raw Input and didn't follow the pressed button. I believe it has something to do with a different error - copy/paste nodes. I might have copied this node from the main and pasted it in a new flow, but it was more than a week ago. Without proper debugging, I can't provide more information.
I confirm this happens all over the bot—all Raw inputs stopped capturing the clicked choices, and the bot doesn't work anymore. @fresh-fireman-491 @crooked-van-25152 Could you please take a look at what happened and why Raw Inputs—>Choices don't work anymore?
What is more, suddenly, the javascript statements started changing by themselves. This picture shows the error I'm getting because for some reason <= changed to this strange character as you can see on the screenshot: https://cdn.discordapp.com/attachments/1229370342611488828/1229395208081375302/image.png?ex=662f8682&is=661d1182&hm=6a917f96d256fa05320b07fd4d74153a6430d942186ea943f7e79e02e5d2e28c&
I assume some changes were performed/updates were made. If that's correct, please perform thorough tests before the updates to prevent the software from breaking. I'm already trying the third day to release the bot and pay for it to run all the time, but I constantly find this type of issue.
Here is additional report_01HVGSNKF6W70JNVDK42X0FDKE with complete information, logs, bot, etc.
f
I think this is something for @rich-battery-69172 to take a look at. It would be breaking if it happened for everyone.
s
It might have to do something with the cache (botpress cache), and others might not recognize it yet. I think it started today around 12:00. I wanted to perform the last test and discovered this error. Moreover, it's strange to see the characters being replaced.
@rich-battery-69172 - After some testing right now, the problem exists only when using a translation agent. When I change language Raw Inputs don't recognize clicked buttons. After changing the language, workflows don't work as designed anymore. Please let me know what to do because I don't see a way how I can fix it. With the translation agent enabled and after switching to a different language (tested: German, Russian, Spanish, ...), flows don't stop in breakpoints like designed. In English, I haven't seen this problem so far.
@fresh-fireman-491 , @rich-battery-69172 , @User —I extended my plan to ensure that there were no limitations. I also got the Always Alive. Unfortunately, nothing has changed. Languages other than English break the Raw Input Choices. Can you support me with those problems? Can you tell me how to fix them, because I would like to promote the bot?
b
hey - I'm having trouble replicating this issue
I ran some quick tests and choices on both raw input and multiple choice cards seem to be working alongside the translator agent
can you confirm if these issues are still happening in a new bot?
s
I confirm. Bot doesn't respond properly, is skipping cards
hm, can you create a brand new bot and see if you're able to replicate the problem there?
s
new bot doesn't behave the same
maybe I will try to disable translation agent and enable it again, what do you think?
b
so your bot is working properly & as expected in a new bot?
s
so the bot doesn't work properly - only new bot with two nodes work properly
can I send you link to the page with failing bot so you can test it by yourself?
b
can you try exporting your old bot and importing it into a brand new bot?
s
I can try
unfortunately disabling and re-enabling the translation agent didn't solve the problem. Will try with a new/imported bot
No, it didn't help. After importing the same problem - he doesn't react properly in different languages
none of the buttons (choices) work - they are not recognized
I have a different, similar bot, and this problem doesn't exist there. It looks like only one bot has this problem and I don't know how to fix it?
@bumpy-butcher-41910 may I ask you for one test? I think I found the reason of this error. Please, create raw input with choices like this: ❓ Answer questions 🔒🆓 VPN for Free 🔒💻🌐 Best VPNs 💰🎁 VPN Special offers 🌐 🇩🇪, 🇪🇸, 🇨🇳, 🇷🇺, 🇵🇱, ...
and test if the card will transition properly - you can select the first node only
@fresh-fireman-491 can you test this as well?
Based on the tests, some characters break the code - in this case, by using special characters I can force the bot to bypass some functions which from the security point of view is critical
b
hm, which special characters do you think are breaking these choices?
s
the icons, I'm testing right now and if I remove the question mark it works
with a question mark, it skips the Raw Input and goes to always and transition to the next node, and in the next node and next workflow continues without stopping
It means, using question mark (just as an example) I can bypass questions (if statements) and go into for example paid content without paying
This problem is only with Raw Input. I have Single Choice with the same or similar icons, and they work properly. This problem exists only with the Raw Input card—sometimes in English but specifically in other languages.
b
can you change these nodes to single choice then?
there's technically no reason to be using raw input cards here anyway, since you're expecting your user to make a single choice
s
Can I use single choice and let the user type his answer and extract it from single choice?
If yes, then what is the difference between Raw Input and Single Choice. Nevertheless, this is a temporary workaround but the risk will remain.
My use scenario is that I let the user click the button but if he types in the question I handle it through "always" and then AI Transitions Can I do the same with a Single Choice card?
I will test it later and let you know.
b
yeah!
there's effectively no difference between the two
s
@bumpy-butcher-41910 @fresh-fireman-491 Unfortunately, switching to a Single Choice card didn't solve the problem. Right now, whenever I type something, the card uses the first button as the default pressed one and transitions using that connection. So, the Single Choice card is different from Raw Input and can't work this way. Unfortunately I need buttons as exit choice from the question. I don't know what is broken, but cards can't transition properly anymore whenever some combination of characters is used. You can test this by using the emojis I posted above or just any you prefer. Please, report this error as urgent to be fixed - transitions are the basic functionalities of bots.
Still testing the Single Choice card - So far, strangely, if I use Single Choice but change the "Type of value to extract" to Raw Input, then it works even with emojis in the choice buttons. https://cdn.discordapp.com/attachments/1229370342611488828/1230134566036049930/image.png?ex=66323717&is=661fc217&hm=0f8c98e117b365bb037e1029d5e30a41efddc67076a1b76b3511acb6ff4b469a&
b
hey there - I'm still having trouble duplicating this issue
I've been testing this with single and multiple choice cards, as well as special characters and messages using the translator agent, and everything is working fine on my end
are you able to see in your bot's logs why it's firing certain transitions?
your logs will tell you why the bot made certain decisions
s
Hi, Sorry for the late response. For this example, I used a completely different account with anything inside - fresh bot. Here is the simplest possible example I can come up with: https://cdn.discordapp.com/attachments/1229370342611488828/1230398528795181067/image.png?ex=66332cec&is=6620b7ec&hm=cb4ef46e6fce21b313761f1a0f72aa285f1eca54559ab44ffa5f4670d22db56f&
I request to change the language, then I use Raw Input to change it, next in following Raw Input I use Choices and for this example connected only correct one I want to press so there is no mistake. It always takes me to the Standard7 node showing an error message. After changing language, I press the first choice button "❓ One" (Jeden), which should take me to the Standard8 with a message "Correct button". Instead, I receive "ERROR" translated to "BŁĄD"
5 Views