https://discord.gg/botpress logo
#🌎general
Title
# 🌎general
f

freezing-carpenter-9818

07/05/2023, 1:29 PM
if you look here, the expression is still yellow even though i have pasted !turn.KnowledgeAgent.responded
e

early-train-33247

07/05/2023, 1:33 PM
Could you share the contents of the transition in yellow please
d

damp-artist-61438

07/05/2023, 1:34 PM
its !turn.KnowledgeAgent.responded
i gave it to him because its suppose to look in the KB then if its not there transition
e

early-train-33247

07/05/2023, 1:34 PM
that's just the label, the expression might be wrong
d

damp-artist-61438

07/05/2023, 1:34 PM
i told him it should look like this
thats what i use
e

early-train-33247

07/05/2023, 1:35 PM
But I think that's a new bug that makes the Expression card think that it's not connected. If you remove the transition and drag it again it should work.
d

damp-artist-61438

07/05/2023, 1:35 PM
e

early-train-33247

07/05/2023, 1:35 PM
@freezing-carpenter-9818 try it out please
d

damp-artist-61438

07/05/2023, 1:35 PM
👍
f

freezing-carpenter-9818

07/05/2023, 1:35 PM
yes so when i paste in !turn.KnowledgeAgent.responded it stays yellow
d

damp-artist-61438

07/05/2023, 1:35 PM
read above
f

freezing-carpenter-9818

07/05/2023, 1:35 PM
whihc kind of means nothing has been inputted
so delete it and start over again? tried 5 times it just stays yellow after pasting !turn.KnowledgeAgent.responded in to the condition feild
e

early-train-33247

07/05/2023, 1:37 PM
You guys are using the responded variable to check if an answer from the KB was found? The right way is to check if the answer is null. Because if you have enabled manual answering on the agent, it won't ever set responded to true, only fill the
turn.KnowledgeAgent.answer
variable So update the expression to
turn.KnowledgeAgent.answer === null
, then add a transition to the node where you manage that
Delete the transition line. And drag it again to the next node
f

freezing-carpenter-9818

07/05/2023, 1:39 PM
you know what you two.... THANK YOU so much
like seriously, so much
both of you
i did this and it worked
ok so we should change it to turn.KnowledgeAgent.answer === null
if i set it to this, it doesnt loop back
!turn.KnowledgeAgent.responded this works perfectly
thank you again guys. just a quick question is there anywhere i can learn !turn.KnowledgeAgent.responded how you got to this, or if there is a list of expression etc?
d

damp-artist-61438

07/05/2023, 2:21 PM
why does it work for me?
that’s weird
it works perfectly
f

freezing-carpenter-9818

07/05/2023, 3:07 PM
for me too
e

early-train-33247

07/05/2023, 3:10 PM
Because you don't have the Manual answering option enabled (it's for making the bot don't respond KB questions automatically). If you ever need to enable it, you would need to change the expression
f

freezing-carpenter-9818

07/05/2023, 3:11 PM
@early-train-33247 are you aware of the name capture issue where it returns {"first":"tas","last":null} when using the stored variable
e

early-train-33247

07/05/2023, 3:11 PM
Not yet, please make a post on #1111009377525186570 so we can troubleshoot
A documentation for the agents in on the works. @bumpy-butcher-41910, do we have an estimate for that?