personality re-write changed post agent update
# 🤝help
a
From @creamy-agency-21997 in the build a bot office hours: > I have a bot that teaches how to DJ and it is based off of my Corgi who knows English and Spanish words. So before the update, the bot would say something like "Hola amigo! Let's learn how to DJ, compañero!" But now it just says the whole thing in Spanish. I didn't change the personality, so it still says "You speak in Spanglish" but since the update it doesn't want to do so
@rich-battery-69172
c
Thanks! The translator agent is off and it is still happening. Here is my entire personality: "You are a fun and friendly DJ that speaks Spanglish."
And this is the example of a response that was originally written in an English "send message" card: "¡Dale, dale! ¡Vamos a escuchar esa pregunta, cabrón!"
r
just to be sure to replicate this scenario my side - you want your chatbot to speak spanglish, based on messages written in Say Cards in full English or full Spanish?
a
"Hola amigo! Let's learn how to DJ, compañero!" <- example of what he wants
c
What I want is everything or most things to be in Spanglish 🙂 So for example, my Capture Card says "Aight, let's hear that question, amigo!" and it used to say various forms of that, but mixing Spanish and English together in its own way. Now it only sends that, and everything else, in full Spanish
r
got it! let's play a bit with your prompt. 1 sec i'll try locally first
do you have KB enabled?
c
Yep! And it searches/answers perfectly
r
ok cool !
c
There are 2 bases I have: the Camelot Key system website, and a static PDF that is the VirtualDj manual. It doesn't get confused at all 🙂
r
oh yeah ok so my side with your current prompt it answers only in spanish. let me try a few variations
c
Sure thing. Take your time
r
is that a bit closer to what you want?
Here's my prompt
c
Interesting!!! Telling it what Spanglish is. I will try now. The funny thing is that in the previous version it knew exactly what to do, but let me see how this goes 🙂
r
yes it may act a bit differently because the only different in the prompt before and after is that the PersonalityAgent should try to preserve the original language
so you may end up having to force it a bit more to ignore that prompt instruction
c
Didn't work 😦 It's surprising because the greeting example actually starts with English. The greeting is: "What's good fam? Soy Linguini your DJ favorito and DJ extraordinare. I'm here to teach you all about VirtualDJ. I'm connected to the most up to date VirtualDJ database. What's good?"
Will try forcing now
r
yeah also make sure that TranslatorAgent is disabled (ie the circle is gray not green)?
c
Circle is definitely grey. Forcing didn't seem to work at a first try... I'm going to turn on TranslationAgent and tell it to Speak in Spanglish
Oh, that isn't editable
Ah, and it requires officially supported languages. I doubt there is a code for Spanglish haha
I was able to force it to speak in English within the prompt, but not Spanglish. Will keep you updated. Thanks for your help and sorry to be such a bother!
I might have fixed it with your help!! Here is the part of the prompt that did the trick: "You do not speak Spanish so forget all Spanish words." - It must be treating Spanglish as a separate language, because that actually made him speak with a balance between the two languages
r
oh!!!!
clever haha. let me know how it goes
5 Views