https://discord.gg/botpress logo
#🤝help
bot repeating question again and again
# 🤝help
w

wonderful-kilobyte-12079

07/18/2023, 4:04 PM
Hi , I am building a bot is repeating same questions again and again !! Attached the node where I am capturing all details and the bot is getting stuck midway and starts repeating the questions. The 2nd pic is a working example of the same. Please help . Thank you!!

https://cdn.discordapp.com/attachments/1130892909600841878/1130892909823148166/Screenshot_2023-07-18_at_17.02.55.png

https://cdn.discordapp.com/attachments/1130892909600841878/1130892910276120737/Screenshot_2023-07-18_at_17.01.43.png

r

rich-battery-69172

07/18/2023, 5:14 PM
@wonderful-kilobyte-12079 does the bot work well in the emulator (studio)? Can you try typing "//state/reset" ?
w

wonderful-kilobyte-12079

07/19/2023, 10:28 AM
thanks @rich-battery-69172 , I tried that . Its still repeating questions. Bot was working fine in Emulator , was just acting a bit slow in response , thats it
s

straight-musician-77995

07/19/2023, 5:40 PM
@rich-battery-69172 @wonderful-kilobyte-12079 is this solved? Having the same issue.
r

rich-battery-69172

07/19/2023, 5:41 PM
@straight-musician-77995 can you share a screen sharing of your bot in the emulator repeating? with the flow and the AI Task ?
s

straight-musician-77995

07/19/2023, 5:41 PM
sure
coming now
r

rich-battery-69172

07/19/2023, 5:42 PM
thanks
And it does the same in the mediafiles.botpress.cloud to test the webchat (to exclude variables inside my website)
I tried this too
I built another chatbot for another client and it doesn't give me this problem. IDK why.
@rich-battery-69172 [SOLVED] I don't know the cause but I exported the project than created a new chatbot and imported the previous. Now it works well. Some information to help you find the bug: at the beginning it was working, then I switched up a lot of nodes, disconnected and connected again and again and it started with the strange behavior. So I guess it's something around the node connections and some weird stuff happening when modifying them
h

high-house-27719

07/19/2023, 7:41 PM
so for solve it i have to export and import in another bot file right?
sono italiano anch io amico
se sai come risolvere possiamo sentirci perfavore?
s

straight-musician-77995

07/19/2023, 7:43 PM
Brooo
ti invio un DM
r

rich-battery-69172

07/19/2023, 8:00 PM
Yeah if you all refresh your Studio then click on each of your problematic AI Tasks, they should update to get the bug fix
w

wonderful-kilobyte-12079

07/20/2023, 11:00 AM
hmm thats fine for personal use , but I am worried about deploying this at a client's end and facing such bugs again . It would be really good to understand why bot would behave such way so that we can build and sell this to business clients more confidently
s

straight-musician-77995

07/20/2023, 11:08 AM
Yeah would be good
Today I had a presentation with a client showing the chatbot I built for him, and despite I thought the workaround of yesterday solved the bug. It didn't and it bugged in front of the client 😓
@User a fix would be awesome
PS: it's not about AI tasks. It does the same for single choice inputs. I mean, I don't have AI task in my chatbot Hope it helps to solve it
w

wonderful-kilobyte-12079

07/20/2023, 11:17 AM
I completely agree with you, and even my chatbot didnt have an AI task, it was simple data capture cards ! yesterday I had to send a chatbot working demo to a client . I couldn't share all the functionalities as it was buggy . And I have a few more demos next week , and I am not sure how confident client will be , if bugs keep happening 😦 @rich-battery-69172 would be super helpful to get your help here . Thank you
h

high-house-27719

07/20/2023, 11:41 AM
I have the same issue, after publishing it you cant edit the bot or it will be bugged.. Would be awesome if TEAM can solve it💪
c

colossal-activity-12523

07/20/2023, 5:12 PM
The change we made recently was to improve the results by using the function calls, with the goal being that we have more control over the output we expect from gpt. So this means that more weights are given to the output variables you configure, and the description you provide to them. The instructions were also changed slightly to account for this change, we had to adjust it yesterday to improve the responses. We did push another improvement like 10 minutes ago. If you are still having issues with the ai task card, would you mind providing me with the content of your card so we can continue improving it?
If you are having an issue with one of the capture card, we would need more information about that (how to reproduce) because we didn't make a change to them for some time now
r

rich-oxygen-43707

07/20/2023, 6:10 PM
s

straight-musician-77995

07/21/2023, 9:13 AM
ye exactly the same
if you use the webchat here https://aimarketinguru.com/ And answer only "SI", you'll get that error I previously recorded a video. @rich-battery-69172 @colossal-activity-12523
Other info to debug: - the chat inside cloud studio never bugs, only when you integrate it in a webchat or telegram (that's what I tried) - the console log in the browser is clear when the problem happens (goes back to the previous node)
Here's another explanation of the problem
Based on what I read from @wonderful-kilobyte-12079 and what I've seen speaking privately with @high-house-27719 ... We are having the exact same problem
Another info that could be useful to debug: when you export the project and import it again on another chatbot, it seems to work a bit but then it breaks again..
if you can fix this the product would be perfect
thanks
@rich-battery-69172 @colossal-activity-12523 There's no AI tasks here. Just single choice input
Is any dev interested and involved in this?
Pardon the Harassment, just wanted to know if this is about to be fixed and I can sleep peacefully tonight. @steep-wire-96122 @cold-motherboard-82208 @famous-jewelry-85388 @witty-football-93730 @early-train-33247 @some-baker-90541 @colossal-egg-20510 @acceptable-gold-88171 @bumpy-butcher-41910
Also if you need more informations about the problem other than the ones I already provided
c

cuddly-secretary-10949

07/22/2023, 1:11 AM
I read this thread and its a relief to realize I am not crazy. I was experiencing the same. Positive side , I gained lots of additional knowledge while troubleshooting.
d

damp-forest-63651

07/22/2023, 1:24 AM
Hi guys. I think i am experiencing the same. In the emulator, everything works perfectly well. On webchat or on whatsapp integration, two remarks: 1- randomly you get the normal flow after many times flows repeated 2- when repeating, it looks like instead of giving the usual or right answer, it is the previous node which is responding, and without reason.
s

some-baker-90541

07/22/2023, 9:10 AM
Hi all, sorry to hear about this issue. We will get to the bottom of it and get it fixed asap. We definitely don't want people thinking they are crazy or not being able to sleep!
s

straight-musician-77995

07/22/2023, 10:47 AM
exactly that
Ook, if you had some insight on how to make it work, pls share ❤️
Thanks Justin, appreciate it
d

damp-forest-63651

07/22/2023, 5:55 PM
ok
e

early-train-33247

07/22/2023, 5:58 PM
Hey guys, this thread got a bit messy. Could you guys please restate the problem you are having and when is it happening?
d

damp-forest-63651

07/22/2023, 6:02 PM
hi @early-train-33247 . I can send a screenshot and explain better so that you can see
e

early-train-33247

07/22/2023, 6:02 PM
Please
d

damp-forest-63651

07/22/2023, 6:13 PM
ok, give me 5 mn
Here is an example oft he bot working well, it is supposed to execute a flow when it is speaking english with the user by asking questions and helping the user reformulate his response
Example in the share bot where everything is fine

https://cdn.discordapp.com/attachments/1130892909600841878/1132377260276596796/Screen_Shot_2023-07-22_at_19.21.35.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132377260670849124/Screen_Shot_2023-07-22_at_19.21.32.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132377261203537930/Screen_Shot_2023-07-22_at_19.21.21.png

Now example of the web integration. You can check by yourself here https://yemi.iwajutech.com. Following are the screenshots
As you can see on the screenshots, the intent is not recongnized, but seems to be recongnized the second time it is typed, and then when the only option available is chosen, it shoe=ws the default message on the first node when the intent is not recognised meaning it does not understand and asking again for what th euser want, so we are starting again, at the beginning.

https://cdn.discordapp.com/attachments/1130892909600841878/1132378733244858449/Screen_Shot_2023-07-22_at_19.25.01.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132378734339563571/Screen_Shot_2023-07-22_at_19.24.54.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132378735325237319/Screen_Shot_2023-07-22_at_19.24.43.png

I can explain more if you want or send the logs
Bur from what i just observed from a week now, when on webchat or whatsapp integration, i dont get the response i am expecting, instead i get response to the previous node, while the discussion is no longer supposed to still be on that node. That's the resume of the problem. I can answer any more question if needed
d

damp-forest-63651

07/22/2023, 6:45 PM
Same thing happening on whatsapp channel.

https://cdn.discordapp.com/attachments/1130892909600841878/1132382795864473680/Screen_Shot_2023-07-22_at_19.42.28.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132382796409749574/Screen_Shot_2023-07-22_at_19.42.25.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132382801681981540/Screen_Shot_2023-07-22_at_19.42.19.png

https://cdn.discordapp.com/attachments/1130892909600841878/1132382802374033508/Screen_Shot_2023-07-22_at_19.42.11.png

c

colossal-activity-12523

07/22/2023, 6:50 PM
Would you mind sending me your bot so I can try it on my side ? If I can replicate the issue it will be a lot easier to get it fixed
d

damp-forest-63651

07/22/2023, 6:52 PM
ok, can i send you the shere link and the webchat and whatsapp channel?
Also sent it privately. Do you need anything else, i am online if needed
Do you mean sending the exported version?
c

colossal-activity-12523

07/22/2023, 7:03 PM
yes
Hey guys, we might have found the issue with the bot repeating itself. The difference between the emulator and the cloud (webchat, integrations, etc) is that there are two different timeouts (session timeout & context timeout) on the cloud. It's a bit complicated, but basically most information is stored in the session (prompt status, workflow variables, etc), and the position in the flow is stored in the context. Session expires after 30 min, and context after 5. So what is probably happening is that you have prompts that are active, and after some time your position is reset at the beginning of the flow, but those prompts are still active. So when you arrive on that node, it may behave differently because of this. We are working on a fix and will let you know when it's done 🙂
d

damp-forest-63651

07/23/2023, 7:28 AM
Thanks @colossal-activity-12523 for the feedback, and the time spent on debugging. Resolving the issue will benefit many people. Wishing you good day while we are all waiting for the good news.
r

rich-battery-69172

07/25/2023, 4:37 AM
A fix has been deployed! Let us know if you still face issues with this
d

damp-forest-63651

07/25/2023, 7:51 AM
Ok. Thanks. I will check and give feedback Thanks for the Work
o

orange-balloon-27116

07/25/2023, 9:25 AM
Good morning, Botpress Team, I hope this message finds you well. Just wanted to share my experience building bots on your platform. It's been fun, and I've enjoyed the learning process. However, I've encountered a couple of issues on the bots I recently built. 1. The most pressing problem I've encountered is the repeated questions during interactions. It becomes problematic as the conversation loops on the same questions, hindering progress. Additionally, when integrating with Google Sheets, I've noticed duplicated variables that have proven challenging to comprehend and troubleshoot on my end. 2. Another concern arises when integrating with apps in Meta, where some sentences are shortened and left incomplete. I've tried troubleshooting on my end, but I'm not sure if it's something I'm doing wrong or if there might be a bug. Therefore, I kindly request your assistance in looking into these matters. I was planning to showcase these bots to potential clients, but with these issues, it might be tricky. Thank you for your attention to this matter. I look forward to your support in resolving these challenges promptly. @User @User The language is Portuguese. 👍🏾

https://cdn.discordapp.com/attachments/1130892909600841878/1133329135033397418/IMG_6412.png

https://cdn.discordapp.com/attachments/1130892909600841878/1133329135343763496/IMG_6403.png

https://cdn.discordapp.com/attachments/1130892909600841878/1133329135679315968/IMG_6405.png

https://cdn.discordapp.com/attachments/1130892909600841878/1133329135935172698/IMG_6404.png

https://cdn.discordapp.com/attachments/1130892909600841878/1133329136211984525/Screen_Shot_2023-07-25_at_10.18.12.png

https://cdn.discordapp.com/attachments/1130892909600841878/1133329136484622386/Screen_Shot_2023-07-25_at_10.16.40.png

l

limited-forest-26830

07/25/2023, 9:52 AM
im having the same issue with my data capture card
w

wooden-monitor-59005

07/25/2023, 10:23 AM

https://cdn.discordapp.com/attachments/1130892909600841878/1133343745207713813/RPReplay_Final1690280223.mov

I’ve got the repeating bot too! It works perfect within the botpress studio but is pretty useless once deployed
l

limited-forest-26830

07/25/2023, 10:35 AM
mine is bugging in the botpress studio :/ idk what was the reason it was perfectly fine yesterday and I havent touched it that much
c

colossal-activity-12523

07/25/2023, 11:52 AM
please retry to deploy, should be fixed
(reload the studio first)
Hey, thanks for your comments! There was a small regression with the fix to repetion, but it should be fixed now if you reload & redeploy. For your second point, probably that there is a limit on the number of characters for a message, i'll add an issue so we can check this out
please retry it now
w

wooden-monitor-59005

07/25/2023, 12:01 PM
I’ll try now 💪
b

best-island-8847

07/25/2023, 12:09 PM
mine keeps repeating the questions:(
c

colossal-activity-12523

07/25/2023, 12:10 PM
can you send me your bot export and tell me how to reproduced?
b

best-island-8847

07/25/2023, 12:16 PM
this is the link: https://mediafiles.botpress.cloud/b60804b5-5585-4ff9-8c60-f68f2684d45b/webchat/bot.html it asks you ur name at first and then it has some questions that u have to choose u can choose whatever u want. You will see that it will repeat the same stuff after one or more choices
o

orange-balloon-27116

07/25/2023, 12:28 PM
Thanks for your response. I’ll look into it & test it. Let’s see how it goes.
c

colossal-activity-12523

07/25/2023, 12:36 PM
did you try to republish the bot? I don't understand the first question it is asking
b

best-island-8847

07/25/2023, 12:36 PM
yes i tried but it does the same thing
for the first question u just need to type ur name
c

colossal-activity-12523

07/25/2023, 12:38 PM
what does your flow looks like?
w

wooden-monitor-59005

07/25/2023, 12:39 PM
Refreshing the studio and the republishing the bot solved the issue of my bot repeating itself! Thanks 🙏
l

limited-forest-26830

07/25/2023, 12:42 PM
refresh the studio like regular site refresh?
b

best-island-8847

07/25/2023, 12:45 PM
this is the start of my flow, after i publish it, for exable if i choose the flow to go in standard16 it goes there and then it should go to standard17 or standard 24 etc but instead it goes back to standard1

https://cdn.discordapp.com/attachments/1130892909600841878/1133379597736611950/137.png

o

orange-balloon-27116

07/25/2023, 12:52 PM
After conducting several tests, there was noticeable progress in the conversation. But, as the conversation continued, I encountered instances of repetition again. Even after selecting a specific option, the same question was asked twice or three times. I’ve attached my export file, kindly take a look and let me know what you think. https://cdn.discordapp.com/attachments/1130892909600841878/1133381241136226344/Chatbot_de_Seguros_-_2023_Jul_25_1.bpz
l

limited-forest-26830

07/25/2023, 12:56 PM
anyone know how to solve repeating question based on logs: 20:55:32debug[Capture] Transformed the extracted value 20:55:32debug[Capture] The extracted answer is 'null'. The user probably didn't answer the question. 20:55:33debug[Capture] Field extraction failed. Input: Bronchitis 20:55:33debug[Capture] Extraction failed (0/2 attempts) 20:55:33debug[Capture] Retrying prompt

https://cdn.discordapp.com/attachments/1130892909600841878/1133382542582632448/image.png

h

hundreds-afternoon-34445

07/25/2023, 1:47 PM
its also in the emulator
g

gifted-minister-2714

07/25/2023, 2:07 PM
I have the same problem when I publish my bot. However, in the emulator it works fine
r

rich-battery-69172

07/25/2023, 4:32 PM
@here can you let us know if you still face this issue after a re-deploy of your chatbot?
d

damp-forest-63651

07/25/2023, 5:05 PM
Hi @rich-battery-69172 i still have the repeating for example welcome message instead of showing the right node actions
r

rich-battery-69172

07/25/2023, 5:20 PM
@damp-forest-63651 hey not sure to understand, can you send me screenshots, a screenshare or an export of your bot?
d

damp-forest-63651

07/25/2023, 5:22 PM
ok
even in the shared emulator, it already repeats message, in fact it shows the first node response. as if i was in that node

https://cdn.discordapp.com/attachments/1130892909600841878/1133451055515054181/Screen_Shot_2023-07-25_at_18.28.34.png

r

rich-battery-69172

07/25/2023, 6:26 PM
@limited-forest-26830 @hundreds-afternoon-34445 @alert-spoon-11852 Let me know if you still face this issue after a studio refresh + republish 🙏
g

gifted-minister-2714

07/25/2023, 7:33 PM
I just published my bot - and it still repeats itself. I checked in the emulator mod - works perfectly fine.
c

colossal-activity-12523

07/25/2023, 7:57 PM
we pushed a fix 35 mins ago, did you try to reload the studio before publishing?
r

rich-battery-69172

07/25/2023, 8:41 PM
@gifted-minister-2714 if you still face this issue, could you send us your botId (from the studio URL), or even better an export of your chatbot + a screenshot of the conversation?
l

limited-forest-26830

07/26/2023, 4:01 AM
Hi Sly, its working now, I wonder what was the cause?
s

straight-musician-77995

07/26/2023, 3:08 PM
Hi @rich-battery-69172 Still having the issue. I exported -> imported in another project Published from scratch still giving the same issue BotID: 97775927-c22e-4278-8637-408ee18d1dcb Chatbot Project 👇 https://cdn.discordapp.com/attachments/1130892909600841878/1133777943211036763/OFFICIAL_CHATBOT_-_2023_Jul_26.bpz
As you can see -> it repeated the same node

https://cdn.discordapp.com/attachments/1130892909600841878/1133778227945558126/image.png

r

rich-battery-69172

07/27/2023, 2:33 PM
Hey sorry for the delay, I tried to reprodue on my side woth your bot and everything works fine. Did you reload the studio, re-publish and cleared the state using
//state/reset
?
s

straight-musician-77995

07/28/2023, 10:53 AM
Hi @rich-battery-69172 I just tried to //state/reset, it told me "SUCCESS: State Reset" Then tried the whole flow the first time and all went fine Then tried again a second time and...
Happened again

https://cdn.discordapp.com/attachments/1130892909600841878/1134438429007020143/image.png

it doesn't happen always
but I am sure that if you try a few times it will happen
l

limited-forest-26830

07/28/2023, 11:56 AM
yea it does appear from time to time, for example right now in my published bot:

https://cdn.discordapp.com/attachments/1130892909600841878/1134454335724593212/image.png

e

early-train-33247

07/28/2023, 10:40 PM
Hey Walter. Glad to know you are liking the platform! 🚀 Sorry these issues have been happening 1. This is a known bug we are working on a fix! 2. Could you create a post here with more details about the duplicate variables issue? 3. WhatsApp limits the choices to around 20 characters unfortunately, I assume other Meta apps as well!
s

straight-musician-77995

08/01/2023, 1:39 PM
@rich-battery-69172 @early-train-33247 nothing here?
c

colossal-egg-20510

08/01/2023, 3:16 PM
@straight-musician-77995 We added a permanent fix for this issue. You can test it again to make sure everything works properly. If there is still an issue, we'll look into it as soon as possible. 👀
b

best-island-8847

08/02/2023, 9:32 AM
It is better for sure but sometimes it keeps repeating
c

colossal-egg-20510

08/02/2023, 3:21 PM
@best-island-8847 oh! Could you provided us with a little bit of information. To be more precise, we made sure to send messages after the bot finished processing the previous one. In certain context, the bot could intentionally repeat it self. For example, a bot will ask the same question if a capture card is configured to retry on failed answers or when using Whatsapp the choice option will send the same messages with different options if there is more than 3 choices (the last one will be addressed soon). 😅 Any information about this issue is welcome! 🐞
b

best-island-8847

08/03/2023, 9:44 AM
For examble I've put a question for the user to go back in the flow if he wants to to see more of the options i've put. When the user chooses to go back it does go back and when he starts choosing some of the options it repeats stuff when it shouldnt. Maybe it intentionally repeats it self like u said but in the test box it works fine.
h

high-house-27719

08/09/2023, 9:05 PM
hello guys, do you solved this issue?
r

rich-battery-69172

08/11/2023, 6:39 PM
@high-house-27719 this has been fixed | can you confirm this works properly now?
e

early-train-33247

08/18/2023, 1:45 AM
This may be a workflow issue. Can you send a screenshot of the nodes that cause the problem?
9 Views