https://discord.gg/botpress logo
#🤝help
Bot not follow the Logic i gave
# 🤝help
b

billowy-plumber-18272

07/19/2023, 10:49 PM
Is it just me or today chatbots are completely unusable? ☹️ they follow their own route trough nodes, but not with the Logic i give to them, If someone can help i have a lot of screenshots !
r

rich-battery-69172

07/19/2023, 11:09 PM
that's unlikely! bots can't really go rogue 😛 can you provide the screenshots?
b

billowy-plumber-18272

07/19/2023, 11:57 PM
Yeah very weird! AN example:

https://cdn.discordapp.com/attachments/1131357059598782594/1131374344011010150/IMG_20230719_173658.jpg

https://cdn.discordapp.com/attachments/1131357059598782594/1131374344317190254/IMG_20230720_015710.jpg

In this case ⬆️ bot would have been triggered the node2 given the single choice i clicked, but triggered the node3

https://cdn.discordapp.com/attachments/1131357059598782594/1131375065049596005/IMG_20230719_173658.jpg

https://cdn.discordapp.com/attachments/1131357059598782594/1131375065473241229/IMG_20230720_015522_672.jpg

In this case⬆️ conversation were in "no answer2" node, and bot should have been triggered the node (5) , but Just repeated itself
r

rich-battery-69172

07/20/2023, 12:03 AM
the same bug happens in italian ?
b

billowy-plumber-18272

07/20/2023, 12:03 AM
Yes
r

rich-battery-69172

07/20/2023, 12:04 AM
any chance you could screenshot the emulator + debugger instead of the webchat?
b

billowy-plumber-18272

07/20/2023, 12:04 AM
Sure, how can i do that
r

rich-battery-69172

07/20/2023, 12:05 AM
in the studio when you talk to your bot to test it out
you click on any message in the emulator and the debugger will show up
make sure to capture the "Logs" panel

https://cdn.discordapp.com/attachments/1131357059598782594/1131376438969372753/image.png

b

billowy-plumber-18272

07/20/2023, 12:06 AM
Ok so i have to retest It on emulator , hold on plesse
r

rich-battery-69172

07/20/2023, 12:06 AM
thanks
b

billowy-plumber-18272

07/20/2023, 12:17 AM
Problem Is the same in this example im in node1 and It triggers the wrong node After i click a certain single choice, i send you 2 screenshots so you can see all the "logs" panel Lines about the issue

https://cdn.discordapp.com/attachments/1131357059598782594/1131379260511236106/IMG_20230720_021658_905.jpg

https://cdn.discordapp.com/attachments/1131357059598782594/1131379260871938169/IMG_20230720_021701_164.jpg

Are you still there?
r

rich-battery-69172

07/20/2023, 4:48 AM
Sorry! I went away for a while. There seems to be an issue with the capture card in your scenario? It parses something completely unrelated. Would you mind sharing an export of the bot with me in DM so I can investigate?
b

billowy-plumber-18272

07/20/2023, 11:16 AM
Ok thanks