shared bot doesn't work properly
# 🤝help
f
When I test the bot in the workspace it works as it is supposed to. However, when I share it, the bot freezes in the middle of the chat and sometimes and it doesn't even answer, or keeps repeating the same question/option. In the screenshots you can see the same chat in the workspace and in the shared bot, and you cann see that in the shared on, the bot just stopped responding while in the workspace it continued normally. How do I solve that issue? as i need to share the bot with a client as a sample and when he tests it, it lagged and froze for multiple times and same happens with me when I share it. Problem ID: f04c4827-0cd5-4f59-af80-81c8e3943102

https://cdn.discordapp.com/attachments/1139572086625554482/1139572086780735488/Screenshot_1540.png

https://cdn.discordapp.com/attachments/1139572086625554482/1139572087007223898/Screenshot_1541.png

h
Same problem here...
m
Same. Lots of skipping messages, freezing, and 500 errors in the logs.
Maybe it's specifically a Webchat problem.
f
Hi just wanted to inform you the engineering team is currently investigating you problem id.
@happy-piano-13767 @most-butcher-34974 if you are also seeing similar behaviour do you mind also submitting a problem report? top left in the studio. YOu can find in this thread how to do that: https://discord.com/channels/1108396290624213082/1135675069495005306
f
Hey guys Can you try it again now? The engineering team pushed a fix
If it doesn't work, please associate a Report ID as JB said with your mesasges 🙂
m
@famous-jewelry-85388 @freezing-printer-49373 my bot is still freezing mid way through. I did put a help chat yesterday and my id but havent heard back.
@happy-piano-13767 @most-butcher-34974 Did you guys have any luck?
h
@microscopic-shampoo-2255 Nah, I'm trying to test it through the website, webchat won't update...
m
yeah same, keep me posted if you get anything. I am in for a long weekend finding a new program if I cant get this fixed
f
hey goose can you provide a report-id and a screenshot of the issue?
m
@rich-battery-69172 helped me out amazingly!
m
Yes it looks like we are in good shape! Thank you!
f
@microscopic-shampoo-2255 can you please share the link where Sly helped you?
m
@famous-jewelry-85388 I am sorry I thought I tagged it
c
I'm also having a problem. Shareable link not working at all, neither is the chat interface in botpress but the editor is working fine. No errors, just no response - https://mediafiles.botpress.cloud/4874b9db-621d-420e-9dab-8f43738b6713/webchat/bot.html - any ideas? Thanks
f
did you try republishing? Can you generate a report-id in a new help thread?
r
@careful-breakfast-3343, did you solve your problem? How?
15 Views