https://discord.gg/botpress logo
#🤝help
Problem with language
# 🤝help
g

gentle-baker-47357

02/07/2024, 9:33 PM
Guys, how can I set language for the bot without translator agent? I need my bot to answer only in Ukrainian, I download kb in Ukrainian language, disable translator agent. But my bot answers in English. It just translate my ukrainian kb automatically.
Also it takes 4k tokens for kb
my kb is ONLY 100 kilobytes
And it taked 2,500 tokens when my kb was in English and 500 kilobytes
f

fresh-fireman-491

02/07/2024, 9:44 PM
Just to clarify, you have disabled the translator agent completely right? I have tested it before and the size of your KB isn't the thing that plays the biggest role in the amount of tokens consumed, it does effect it but not as much as the output and input. Based on the screenshot you provided you got a decently sized output from it, my guess is that that is the reason why you are spending 4k tokens on just the knowledge agent. To decrease the amount of tokens used you could try and make your KB more concise and have less redundant information, maybe even make multiple KB's for different topics.
g

gentle-baker-47357

02/08/2024, 7:20 AM
Yes, I’ve completely disable translator agent
About kb. I have 4 small topics in kb for only 100 kilobytes
And kb is smaller then previous version that charged 2500 tokens
And why my kb answer in English if all my kb is in Ukrainian
f

fresh-fireman-491

02/08/2024, 7:42 AM
The tokens used depends mostly on the input and output of the bot. If it has to generate an answer from a lot of chunks it will use more tokens. That is why making your KB more concise will help. Maybe @famous-jewelry-85388 can give us an answer why its answering in English?
g

gentle-baker-47357

02/08/2024, 8:18 AM
The size of my database became 4 times smaller than the last one. And the number of tokens has grown to 4,000.
from 2400
And still my translation issue is relevant. How can I make my bot be programmed only in Ukrainian. Given that all commands and database are already in Ukrainian
Maybe it's a bug because my base is not in English?
I managed to fix the translation problem by disabling the Personality Agent. But the problem with KB is still here. I have 4 optimised small text documents in Ukrainian weighing only 100 kilobytes. But I pay for query Knowladge base 4000 tokens, it is more than people with 80 megabytes database!
Here is my documents