https://discord.gg/botpress logo
#🤝help
My ChatBot Is Spitting Out The Name Of The Variable Instead Of The Value?
# 🤝help
c

clever-whale-49695

01/05/2024, 10:54 PM
So I followed the video "Create an AI Chatbot with Conversational Memory like ChatGPT" because that's what I want my bot to be able to do. I followed along with the tutorial and got it working just like it works in the video. Next I want to try to integrate it into an existing bot my team has been working on. In this one, the bot gives you a greeting and a Single Choice node, and one of those choices is "ask a general question" which I connected to an AI task node built exactly like the one in this video. But when I ask it a question, it always responds with "@workflow.response". Like that actual string, not the value of the variable of the same name. I really have no idea what could be happening. Has anyone encountered this? I'd be grateful for any help. I'm brand new to botpress (but not to developing, though my experience is limited). EDIT: I know there's a typo in these screenshots lol (workflow.reponse). But I fixed it, and it still does the same thing, just with the correct spelling 😦
f

fresh-fireman-491

01/06/2024, 6:26 AM
How have you set up your AI Task? Could you add a screenshot of the whole AI Task
I would set the Raw input card to be above the AI Task. This is so that once the user selects "Ask a general question" they will be able to ask a question before it just tries to generate the answer.
This is how I would set up your open_ended_v3 node. Raw input card saying something like "What would you like to know?" AI Task to respond to that. Text card printing out the response from the AI Task. Then continue with it like you used to
j

jolly-policeman-82775

01/06/2024, 9:37 AM
i would set the raw input above the ai task so that the user can ask a question first
oh lol, you already solved this