Knowledge base
# 🤝help
I have 3 questions: 1. If my knowledge base is not in English, when I write its description, should I write it in the language the knowledge base is written in? Or should I stick to English? 2. Can I enable only one knowledge base for a node? For example, the user chooses one of these options: agriculture, automotive, chemical. I have a knowledge base for each one of them and when the user makes their choice, I want only the specific knowledge base to be enabled. Is that possible? 3. This is not really related to knowledge bases, but I set my langauge to romanian, but sometimes my chatbot translates my text cards in english (they are written in romanian). Can I fix this myself or is it a bug?
try this, set user Language at top of your node card

That s what I did, didn t work. When I disabled the translation agent it worked, but I will need the translation agent for when the bot starts accessing the knowledge base, and I don t know how to work around that..
Hey @loud-account-37644 ! 1- Both will work, for the sake of consistency you can stick with the same language across your kb. 2- Not yet, we're working on a way to improve the control of the kb and what it outputs. For now, you can use transitions to filter what is shown to the user. Basically you'd have to enable manual answering in the knowledge agent, then use a transition that would filter which kb you want to answer using this expression event.kb.results[0].kbId === 'your kb id' (your kb id can be found in the json tab of your debugger) and then show the answer generated by the kb in the following node 3- The way @curved-traffic-50479 described is correct, can you make sure you have "automatically detect user language" turned off in your translator agent?
3- Yes, it is turned off. It automatically translates my text card and the single choice card from romanian to english