https://discord.gg/botpress logo
#🤝help
Knowledge Base doesn't find all pages of my website
# 🤝help
s

steep-quill-83165

01/09/2024, 2:56 PM
In the knowledge base, I cannot integrate my website so that all the pages of the website are indexed. So that the chatbot can fetch the information it needs from my website to answer users' questions.
c

crooked-van-25152

01/09/2024, 3:40 PM
Hello! So the bot is only finding the main page? Try making the sitemap available at https://www.YOURWEBSITE/sitemap.xml, so that the bot can crawl it.
s

steep-quill-83165

01/09/2024, 4:20 PM
I didn't succeed, what should I do?
c

crooked-van-25152

01/09/2024, 4:53 PM
The other option would be to save the information in document and then upload the document to your KB.
s

steep-quill-83165

01/09/2024, 7:19 PM
@crooked-van-25152 yes but more longer because we have a lot of information and document
c

crooked-van-25152

01/09/2024, 8:12 PM
easiest way is trying to make the sitemap available!
then, the bot can crawl all pages
s

steep-quill-83165

01/10/2024, 9:53 AM
how can i do it ? what are the steps to make the sitemab available ? Thank you !!!
c

crooked-van-25152

01/10/2024, 9:06 PM
This isn't something that can be done within Botpress. Google and YouTube will be your best friends here 🙂
e

early-train-33247

01/11/2024, 3:14 PM
You can also leverage ChatGPT or Bing Chat to guide you to create a sitemap for whatever architecture you have
s

steep-quill-83165

01/11/2024, 3:17 PM
yes thank you for your answer !
@early-train-33247 @crooked-van-25152 I have a sitemap but when I enter it in the KB, it detect only 1 page
c

crooked-van-25152

01/11/2024, 5:24 PM
Maybe it has to do with the way your sitemap was set up (someone else was facing the same issue yesterday). Try switching from "a website" to "specific web pages", then just paste your list of urls, it will put each one in a separate input.
Let me know if that fixed the issue!
s

steep-quill-83165

01/11/2024, 5:49 PM
so i have to put each pages of my website ?
c

crooked-van-25152

01/11/2024, 7:03 PM
Url should be : www.YOURWEBSITE.sitemap.xml so that the bot can crawl it.
f

flaky-ability-96739

01/15/2024, 2:02 PM
For me it helped to put in
https://www.mysite.com/sitemap.xml
into the field instead of
mysite.com
- though this should ideally be supported as well.