How to disable prompt caching?
# 🤝help
p
How to disable prompt caching for AI Generate Text and similar commands? Problem: The responses are cached and therefore always the same. Goal: I want to disable prompt caching to get more unique results for certain AI tasks.
q
I don't know how to disable it, but here's some solutions. (My previous comments regarding something similar in here https://discord.com/channels/1108396290624213082/1170760399075954709) My guess is that Botpress caches ChatGPT requests&responses, which is recommended if the service has a lot of users. When looking at the logs for the AI Task or AI Generate Text result, it says "cached: true." That's why if we, bot builders, ask the same questions, we get the same answers. The first option is to always change the question. If you ask three Algebra 1 or 2 questions, or ask five, or ask twenty, the answers will change. The problem is that it's still not random enough 👎 The second option is to replace the AI Task or AI Generate Text with an Execute code card and ask GPT-4 (or GPT-3.5 turbo) using your own API key. Then you will always get different random responses because you are directly using the OpenAI API. The problem is that it can be quite expensive 💸 The third and the best option (in my opinion) is to create a Knowledge Base table from the best Algebra sources or ask ChatGPT to generate 100 Algebra 1 or 2 questions like I did and then randomize the answers. Using the Execute code card, chatbot can select one random question from the KB table 💎 ⬆️ Those were my previous answers in another topic. For your use case, using Personality Agent might also be a good option. I have not used it so much, but in my experience, with the correct prompting the answers can be quite random if needed.